Oracle Connections via Javelin fail with ORA-01017: Invalid Username/password.
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Article ID: 106197
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Updated On:
Products
CA Test Data Manager (Data Finder / Grid Tools)
Issue/Introduction
Oracle Connections via Javelin fail with "ORA-01017: Invalid Username/password." when the credentials are known to be good and work via other components (Datamaker, Portal, SQL Developer, SQLPlus, etc).
Cause
Performing a Network sniffer trace would show that the password sent to Oracle is blank, empty or null:
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This only happens when FIPS is enabled on the system running Javelin.
Environment
Release: Component: TDMJAV
Resolution
This is a known issue with the Oracle ODP.Net (Oracle Data Provider for .NET) components. See Oracle Doc ID 1937500.1 and/or Oracle Bug 17322941 for additional information.
To work around this problem, disable FIPS in the registry by setting the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy\Enabled" value to "0".