The Enterprise Dashboard Server at 'http://${installer:enterpriseDashboardHost}:1506' could not be contacted
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The Enterprise Dashboard Server at 'http://${installer:enterpriseDashboardHost}:1506' could not be contacted

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Article ID: 106112

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

Start the Registry, and it reports it is up at first using the entry ./RegistryService status.

After a few minutes, it reports that it is stopped.

In the registry.log I see this error:

The Enterprise Dashboard Server at 'http://${installer:enterpriseDashboardHost}:1506' could not be contacted, and no current activation was found in the local activation cache for this registry.

Environment

All supported DevTest releases.

Cause

In the lisa.properties file this is defined:

devtest.enterprisedashboard.host=${installer:enterpriseDashboardHost} 
devtest.enterprisedashboard.port=${installer:enterpriseDashboardPort} 
devtest.enterprisedashboard.https.enabled=false 

The Registry is looking for an Enterprise Dashboard running on URL:

'http://${installer:enterpriseDashboardHost}:1506' 

The variable ${installer:enterpriseDashboardHost} is not being recognized.

For some reason on this install on the Linux machine it is putting those values instead of 

devtest.enterprisedashboard.host=localhost
devtest.enterprisedashboard.port=port
devtest.enterprisedashboard.https.enabled=false 

This has been reported before.

Resolution

Since ${installer:enterpriseDashboardHost} and ${installer:enterpriseDashboardPort} had not been defined, the Registry will not start.

The workaround is to update the lisa.properties file to:

devtest.enterprisedashboard.host=localhost
devtest.enterprisedashboard.port=1506

If the Registry had been running on a different machine then localhost should reflect the hostname of where the Enterprise Dashboard is running.