Events not seen in CAPC

book

Article ID: 106090

calendar_today

Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After upgrade Events are not seen in the Performance Management.

We see the following error is seen in the Data Aggregator /opt/IMDataAggregator/apache-karaf-2.4.3/data/log/karaf.log* files (your installation path may vary if not default).

ERROR | EventPush | 2018-07-06 07:51:44,269 | EventProducerWS | or.eventproducer.EventProducerWS 945 | a.im.NPCConnector.bundle | | Failed to push xxx events: org.apache.cxf.interceptor.Fault: Marshalling Error:

It also references the wrong host name or IP address for the Performance Management server.

Another place to look is the DA:8581/rest/emregistration page. The eventConsumerURL should point to the correct Performance Management host but may not if this error is seen.

Cause

Wrong IP address registered with the DA

Environment

All supported Performance Management releases

Resolution

To trouble-shoot do the following:

Run the following from the Data Aggregator : 

    curl -v http://<expected IP>:8281/EventManager/EventManagerWS.asmx?wsdl 

This command should succeed.  If it doesn't then the IP is wrong in the event manager general table possibly because there are multiple NICs on the box

Do the following:

  • Edit the Event Manager data source and change the IP in the Host Name dialog box to the correct IP address. This is going to update the "General" table for the EM database after it syncs.  You can verify that by doing the following

        mysql -unetqos -pPASSWORD em

    Replace PASSWORD with your MySQL password. 

        select * from general; 


  • Assuming it updates run the following SQL to identify the sourceid of the Data Aggregator data source:

         select sourceid, sourcetype,consolename from netqosportal.data_sources2 where SourceType = 262144;

    Example output:
    +----------+------------+------------------------------------------------+

    | sourceid | sourcetype | consolename                                    |

    +----------+------------+------------------------------------------------+

    |        3 |     262144 | Data [email protected] |

    +----------+------------+------------------------------------------------+

    In that example the sourceid is 3, your installation may have a different sourceid.

  • Take the sourceid value for the Data Aggregator Data Source form the previous step and run the following SQL:

        update em.data_sources set LastEvent=0,ConsumerID=0 where sourceid = <DA_SourceID>;

        Example:

        Using the example above (again your id may vary) you would run:

        update em.data_sources set LastEvent=0,ConsumerID=0 where sourceid = 3;  

  • This will re-register the Event Manager with the Data Aggregator. It may take upwards of 15-20 minutes for the values to transfer around via normal synchronization cycles in Performance Management.

  • The errors will be resolved when we see the eventConsumerURL value on the http://DA:8581/rest/emregistration page reflecting the correct Performance Center server host name or IP address.