Timed out attempting to connect fast channel to web
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Timed out attempting to connect fast channel to web

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Article ID: 106067

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After restart SDM server the service appear running but trying to access Web is showing the following message error: " AHD4409 pdmweb is unable to connect with the webengine "

In logs files when service started:

jsrvr.log
07/11 12:05:50.820[Thread-9] ERROR SLUMP 340 Timed out attempting to connect fast channel to web:local
07/11 12:05:50.821[Thread-9] INFO SLUMPTC 403 Error al conectar con el slump. Compruebe el daemon del servidor.
07/11 12:07:20.102[TCP_port-Read:Slump_nxd] INFO TCP_port 1163 Discarded message from <SERVERNAME> to unknown receiver *
07/11 12:07:20.104[TCP_port-Read:Slump_nxd] INFO TCP_port 1163 Discarded message from <SERVERNAME> to unknown receiver *

pdm_tomcat.log
jul 11, 2018 12:03:19 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler [http-nio-8080]
jul 11, 2018 12:03:19 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 5586 ms
java.net.SocketException
at com.ca.ServicePlus.pdmweb.SLUMPTC.startFastChannel(SLUMPTC.java:908)
at com.ca.ServicePlus.pdmweb.SLUMPTC.initSlump(SLUMPTC.java:391)
at com.ca.ServicePlus.pdmweb.SLUMPTC.run(SLUMPTC.java:944)

stdlog.0

07/11 12:04:20.82 <SERVERNAME> slump_nxd 3540 ERROR server.c 3744 Unable to handle fast-channel request from 21433|pdmweb:CASMAPP#4ec0e9e8:1648a1528d8:-7fff|PDMWEB to 21433|web:local|slump_cbf; reason: Process web:local has not enabled fastchannel yet

Environment

All Supported Versions

Cause

Issue is related to multiple NIC cards on server and there was a time out attempting to connect fast channel to web:local on the appserver.

The connection cannot reach the slump because is not routing to the correct NIC associated to SDM.

Resolution

Workaround 1:

Configure Priority to NIC that has the SDM server IP configured.
(Refer to the Microsoft support KB article from additional information)

Workaround 2:

- On each server, open the NX.ENV file and locate the following lines:

# Uncomment this to turn off Fast Channel

! NX_NOFASTCHAN=1

- Remove the leading exclamation point and space in front of NX_NOFASTCHAN. The line should now look like the following:

NX_NOFASTCHAN=1

- Save changes and restart server.




Making this modification will disable Fast Channel communication entirely, which will also remove those error entries from logs.

After these changes, restart servers services in this order:

Start SDM-BG server
Start SDM-Stby server
Start SDM-APP servers for webservices

Additional Information

How to configure priority to NIC in Windows:

https://support.microsoft.com/en-us/help/2526067