Non-Administrator users cannot launch workbench
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Non-Administrator users cannot launch workbench

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Article ID: 105917

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Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister CA Harvest Software Change Manager

Issue/Introduction

After installing SCM Client or SCM Workbench Only client on a Windows Server we find it won't run when just double clicking on the icon to launch.

For the Administrator-level users, if they right-click and select "Run as administrator" when starting Workbench or Administrator Tool, we find that this works correctly.

For non-administrator users, even when selecting "Run as administrator" they see:

An error has occurred.  See the log file C:\Users\<userid>\.cascm\workspace\.metadata.log
- or -
An error has occurred.  See the log file C:\Users\<userid>\.cascm\workspaceAdmin\.metadata.log

and the .log file shows

java.lang.IllegalStateException: Workbench has not been created yet.

 

Environment

CA Harvest SCM Workbench client v13.0.3 and higher
Windows platforms

Cause

The "Program Files" directory on Windows is typically considered a system-protected area, and applications installed are subjected to additional security restrictions. Harvest needs to be able to modify files within its own installation directory, for example: “C:\Program Files\CA\SCM”.  It may run into problems if the file or folder is marked "Read Only," or the user does not have the appropriate permissions.

Resolution

One solution is to add the needed users to the local Administrator group on the Windows server, if company policy allows.

Another solution is to install SCM to a custom folder outside the "C:\Program Files" area.  Other folders on the computer do not carry the same security precautions and restrictions as those within "C:\Program Files"

The third solution is to grant regular users "Full Control" permissions to the "C:\Program Files\CA\SCM" folder.  To do this:

  1. In Windows Explorer, navigate to the "C:\Program Files\CA\SCM" folder.  Right click on this folder and select "Properties"
  2. Click on the Security tab 
  3. Click "Edit" 
  4. Select the "Users" user group in the top list box and check the "Full Control" checkbox below. 
  5. Click OK to confirm. 
  6. After this Workbench can start normally for all users.