Connector Server crashes when changing an endpoint's exchange server: Modification failed: Connector Server Modify failed: code 51 (BUSY): failed to modify entry

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Article ID: 105796

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

 The following error is observed when trying to update the Exchange server for an endpoint via Provisioning Manager.

:ETA_E_0007<MDI>, Active Directory Endpoint 'ADPROD' modification
failed: Connector Server Modify failed: code 51 (BUSY): failed to modify
entry:
eTADSDirectoryName=ADPROD.eTNamespceName=ActiveDirectory,
dc=prod,dc=etacom: [email protected]: JMDI: Failed to activate
connector on proxy connector server: localhost:20402; socket closed
(ldaps://myserver155.ca.com:20411)

CCS connector server crashes and restarts.

Cause

A crash dump indicates that the problem is residing in the RPC layer. It seems something is wrong with network/DNS . Hence, unable to connect to the RPC server.

ERROR_CODE: (NTSTATUS) 0x6ba - The RPC server is unavailable.

EXCEPTION_CODE: (Win32) 0x6ba (1722) - The RPC server is unavailable.

STACK_TEXT:
02bdec58 7473fb4a 000006ba 00000001 00000000 KERNELBASE!RaiseException+0x48.....

This problem is happening while retrieving all domain controller server’s details from primary DC (DNS) by using RPC calls. This is used for failover purposes.

Environment

Release: 14.x
Component: IDMGR

Resolution

We can bypass this failure by using a configuration file which is located in
<PS_HOME>\data\ads\<directory-name>.DNS (NOTE: directory-name is same as endpoint name).

<directory-name>.DNS need to be configured with all available DC server details - the order of the servers in the list is important therefore the DCs which are likely to be used (DC as well as Exchange servers) should be listed first.