Policy Engine memory leak
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Policy Engine memory leak

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Article ID: 105527

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Updated On:

Products

CA Security Command Center CA Data Protection (DataMinder) CA User Activity Reporting

Issue/Introduction

A memory leak was identified in the CA Data Protection Policy Engine Service "WgnPESV64" while processing RTF (Rich Text Format) files using Rich Edit Controls.  This was addressed in part by FIX:RO96348 (incorporating Server_15.20_HF075, Server_x64_15.20_HF076, Client_15.20_HF077and Client_x64_15.20_HF078) See Policy Engine terminates unexpectedly for more details. However a further  memory leak was exposed and memory consumption continued to increase.

 

Environment

CA Data Protection 15.2 Policy Engine running on Windows 2012 R2

Cause

The underlying cause of the memory issues are caused by the Windows 2012 R2 Operating System

Resolution

The resolution to this issue comes in three parts.

(1)  Install FIX:RO96348 (incorporating Server_15.20_HF075, Server_x64_15.20_HF076, Client_15.20_HF077and Client_x64_15.20_HF078) This fix is available to download from the CA Support Portal (http://support.ca.com)

(2)  Microsoft has released a fix to address the memory leak issues identified during the conversion of Rich Text (RTF) to Unicode on Windows 2012 R2 machines.

https://support.microsoft.com/en-us/help/4041685

(3)  Install CA Data Protection 15.2 FIX:SO04070 (incorporating Server_15.20_HF0183, Server_x64_15.20_HF0184 and Client_15.20_HF0185). This fix is available to download from the CA Support Portal (http://support.ca.com) and includes the following binaries:

client\wgnsm.dll - 15.20.4645.0 - 4-Jun-2018
client64\wgnsm.dll - 15.20.4645.0 - 4-Jun-2018
 

Additional Information

Orchestria, Orchestria APM, Oechestria EPM, CA DLP and CA DataMinder are previous brand names for the product known as CA Data Protection