Default value of the Relative Date type parameters gets changed once the user misses filling a mandatory field

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Article ID: 105297

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Default value of the Relative Date type parameters gets changed once the user misses filling a mandatory field.

Steps to reproduce:
  1. Login CA PPM as an Admin user. 
  2. Go to Home --> Reports and Jobs. 
  3. Under the Reports tab, search for Report Type = Resource Availability. 
  4. Click on the result to see the Report properties page. 
  5. Check that, for the "Start Date" parameter, Relative Date radio button is already selected as the default option, with the value "Start of Current Month". 
  6. Remaining mandatory fields (marked with a Red Star) are all filled up. 
  7. Select the "period type" parameter and set the value to [--Select--], that is blank. 
  8. Click on Submit. 
  9. The report gives the ERROR "NJS-0119: At least one parameter is invalid. Check the parameters and submit again" which is expected as one of the required fields was left blank. 
Expected Results: All the other Parameters should retain their default values as there was no change made to them. 
Actual Results: Start Date parameter is now having the "Specific Date" option with a blank value. 

Cause

Due to defect DE39930

Environment

CA PPM 15.3, 15.4

Resolution

The defect DE39930 has been fixed by the Development team and the fix is targeted to be ported in 15.4.1 Patch 1.
Patch 1 for PPM 15.4 Service Pack 1 will be released by the end of August 2018.