Client Automation - DSM Reporter Grayed Out in CA Client Automation
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Client Automation - DSM Reporter Grayed Out in CA Client Automation

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Article ID: 105206

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

The DSM Reporter option is grayed out within the DSM Explorer in CA Client Automation.

Environment

Client Automation - All Versions

Cause

Newer versions of the standalone SQL Native Client Redistributable Tools do not include OSQL.EXE which is required for DSM Reporter to work properly.

Resolution

The DSM Reporter option is grayed out when it is not installed with the DSM Explorer.

There are two main reasons for this situation, the most first, and most basic of these would be that you are running a remote DSM Explorer without the Reporter component being installed. This is the default state and will be the case for most remote DSM Explorer installations. To resolve this, simply install the required DB connectivity prerequisites (listed in the article below) and deploy the DSM Explorer Package procedure called simply 'Install' (as opposed to the default which is 'Install (without reporter)) which will update the existing installation with that component.

If DSM Reporter is already installed and you see this issue, then a required DB connectivity component is likely missing or incomplete, preventing the option to launch DSM Reporter from being permitted. Unlike the DSM Explorer, the DSM Reporter must connect directly to the MDB Database server to perform its functions and thus requires specific Microsoft Client Tools components to be installed on the system in order to function. If the required items are incomplete, then the option to launch the DSM Reporter will be automatically restricted.

Since newer versions of the standalone SQL Native Client Redistributable Tools do not include OSQL.EXE, this cannot be used as an install media to meet the DSM Reporter requirements. To ensure the required item is installed on your system, please make sure to install Client Tools from a full Microsoft SQL Server installation media, selecting the following components in the 'Feature Selection' screen of the Microsoft SQL Server Setup:

1. Client Tools Connectivity
2. Client Tools Backwards Compatibility
3. Documentation Components*
4. Management Tools – Basic

*Optional item

Now relaunch your DSM Explorer and check the 'reporter' option again. It should no longer be grayed out.

Alternatively, you can try the following to bypass the error, but this is not recommended and may or may not be sufficient for Reporter to function:

From a computer with full SQL Server installation, copy the following files to the machine where DSM Reporter is being installed**.
    ...\Microsoft SQL Server\110\Tools\Binn\OSQL.EXE
    ...\Microsoft SQL Server\110\Tools\Binn\Resources\1033\osql.rll

**Paths may differ with SQL Server version.

NOTE: In general, the SQL version installed in this case should match the version used by the Domain or Enterprise Manager for best compatibility.

Additional Information

Reporter cannot be installed

Client Automation - DSM Reporter is not connected to a database . Article ID: 22069