cancelled steps during a deployment
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cancelled steps during a deployment

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Article ID: 105089

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

While running a deployment I see that my step is getting cancelled without any kind of forewarning or error. 

 

Environment

CA Release Automation 6.x and above. 
This will likely happen in version 5.x also. 

Cause

This will happen when the agent is unable to find an appropriate .jar file used by an action in the process. If a missing .jar file is the cause of your cancelled steps then you would see messages similar to the following in the nolio_all.log and/or nolio_action_exe.log file:
2018-07-05 17:07:31,905 [Communication Msg Processor-4] ERROR (com.nolio.platform.shared.datamodel.Action:92) - com.nolio.platform.shared.executables.actions.nexus.DownloadNexusArtifactByUrl
java.lang.ClassNotFoundException: com.nolio.platform.shared.executables.actions.nexus.DownloadNexusArtifactByUrl

2018-07-05 17:07:31,907 [Communication Msg Processor-4] ERROR (com.nolio.platform.shared.flowcontrol.service.FlowControlService:87) - failed initialize flow for job[32768], jobServerId[32768].
java.lang.RuntimeException: Failed to create action from ActionProxy[null:ActionProxy]

NOTES: 
  1. The problem doesn't have to be related to using a nexus action. The problem could happen for an action from an action supplied by an action pack not installed into Release Automation by default. 
  2. If the step getting cancelled due to the missing action pack .jar file is in the pre-deploy phase then the job can show as: 100% Initialization Failed
  3. If the step getting cancelled due to the missing action pack .jar file is in the deployment phase then the job can show as: 100% Deployment Failed (though the % is likely dependent on how many steps complete by the time the step gets cancelled). 

Resolution

If you see the ClassNotFoundException message followed by "failed to initialize flow for job" message in the agent logs then identify which action pack you need to install. Then install the action pack. Before you install the action pack you must manually download the action pack .jar file and its dependency file (if there is a dependency). You can try checking to see if the action pack is listed as an installed action pack and if it is not then you can install it 

Checking For Installed Action Packs
You can check for action packs that the system thinks are installed from both the ROC (Release Operations Center) and Automation Studio. 
  1. Release Operations Center
    • Login to the ROC as a user with superuser privileges.
    • Navigate to Administration -> Action Management.
    • Select the "Installed Packs" tab. This will show you the action packs the system believes are installed.
  2. Automation Studio
    • Login to Automation Studio as a user with superuser privileges.
    • Navigate to the Administration -> Action Management.
    • The list of action packs are those that the system believes are installed.

Downloading Action Packs
You can download action packs from the following locations:
  1. https://support.ca.com/us/product-content/recommended-reading/technical-document-index/ca-release-automation-action-packs.html
  2. https://ftp.broadcom.com/user/downloads/pub/dpm/ReleaseAutomationActions/ActionPacks/

Reinstalling Action Packs
You can install the action pack in one of two ways.
  1. Release Operations Center
    • To reinstall an action pack that CA Release Automation thinks is already installed using the Release Operations Center (ROC) you will need to login to the ROC as a  user with superuser privileges.
    • Navigate to Administration -> Action Management.
    • Select the "Installed Packs" tab. 
    • Click on the "Import" button. 
    • Navigate to the folder where you saved the action packs .jar file (and dependency.zip if the action pack has one) to select the file and open it. If the action pack does have a dependency.zip file then you need to import it too.
  2. Automation Studio
    • To reinstall an action pack that CA Release Automation thinks is already installed using Automation Studio you will need to login to the Automation Studio as a  user with superuser privileges.
    • Navigate to Administration -> Action Management.
    • Click on the "+" button.
    • Navigate to the folder where you saved the action packs .jar file (and dependency.zip if the action pack has one) to select the file and open it. If the action pack does have a dependency.zip file then you need to import it too. 
Note: 
Each action pack is accompanied with a .pdf that outlines installation, prerequisite, and supported versions. It is always recommended to review this.

Installing Action Packs
  1. Release Operations Center
    • To install a new action pack using the Release Operations Center (ROC) you will need to login to the ROC as a  user with superuser privileges.
    • Navigate to Administration -> Action Management.
    • Select the "Available Packs" tab. 
    • Search for the action pack you are interested in using the list of packs. You can also type in the search field to filter for something. Example: weblogic
    • If you found an action pack that you would like to install then click the checkbox next to it. Click the "Download" button once you've selected all the action packs that you want to install.
  2. Automation Studio
    • To install a new action pack using Automation Studio you will need to login to Automation Studio as a user with superuser privileges.
    • Navigate to Administration -> Action Management.
    • Click on the "+" button.
    • Navigate to the folder where you saved the action packs .jar file (and dependency.zip if the action pack has one) to select the file and open it. If the action pack does have a dependency.zip file then you need to import it too. 
Note: 
Each action pack is accompanied with a .pdf that outlines installation, prerequisite, and supported versions. It is always recommended to review this.
 

Additional Information

One reason why a management server may not have the action packs that the CA Release Automation management server thinks it has is migrating your management server. If you stand up a new management server and point it to a database previously used by a management server where the action packs had been installed then the new management server will think (according to the database) that x, y, and z action packs are available. But the files are stored in different folders on the management server so you will need to reinstall the action packs in order for all of your processes to run as expected.

If you have migrated your management server then you should also look to see if there were any custom action packs that might need to be brought over to the new management server. Custom action packs can be found by looking at the list of installed action packs and either:
  1. seeing that they do not follow the standard naming convention used by action packs created by CA (ex: nolio-<integration point>-actions or ca-ra-<integration point>-actions).
  2. not being able to find something in your list of installed action packs on the action pack download pages mentioned in the Resolution section above. 
It is not safe to simply migrate all files from one actionslib folder on a management server to another. But if you do find that your original management server has a copy of a custom acton pack that you need to bring over to your new management server then you should be able to find it in the <ManagementServerInstallFolder>/actionslib folder.