JMS-DATA relating to catalog
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JMS-DATA relating to catalog

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Article ID: 10504

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

JMS-DATA log files (%USM_HOME%\logs\jms-data) may grow to a few gigabytes and take up disk space on the Catalog server. 



What is JMS?

JMS is the Java Messaging Service which is used internally by Service Catalog to communicate between components (Events-Rules-Actions for example). It is also used for communication to external components like PAM.

Environment

Windows

Cause

With catalog version 12.9 and 14.1 ,   the JMS-DATA is cached in %USM_HOME%\logs\jms-data  folder .  Due to some issues ,   the data under that folder can grow abnormally and sometimes even  corrupted . 

Resolution

A.    With catalog 12.9 version or catalog 14.1 version ,  you can manually clean up this folder to remedy the situation if the JMS data is corrupted  : 

1. Stop Service Catalog
2. Delete all the files under %USM_HOME%\logs\jms-data
3. Start CA Service Catalog


B.  Starting  17.x   version,   this issue should be addressed .     Please note that :

Starting from 17.x version ,  the underline JMS structure is changed :     The JMS data is no longer located under %USM_HOME%\logs\jms-data\  , instead , it is located under %USM_HOME%\jms-data\