Error when Attaching files to xFlow Service Point ticket
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Error when Attaching files to xFlow Service Point ticket

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Article ID: 104902

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

The following error appears when attaching a file to xFlow/Service Point ticket:

IMS1001-File extension .XXX is either upload prohibited or it does not match the content type application/XXX


If you check the C:\Program Files\CA\xFlow\APPS\logs\incidentMS.log file you may see an error similar to this:

ERROR - <date> <time> [c.c.c.f.security.FileValidator] - File extension (.rar) does not match the content type (application/x-rar-compressed; version=5)

Environment

Service Desk Manager 17.x
xFlow / Service Point 17.x

Cause

Service Point is able to analyze each file submitted for upload to determine the content type, and then checks the "attachments.allowed-content-types" list to see if the combination of the file's extension and type of content appears in that list. 

If it does not, you will see an error message similar to what you reported.  The C:\Program Files\CA\xFlow\APPS\logs\incidentMS.log will show a corresponding message like this:

ERROR - 2026-03-04 19:26:52 [c.c.c.f.security.FileValidator] - File extension (.rar) does not match the content type (application/x-rar-compressed; version=5)
ERROR - 2026-03-04 19:26:52 [c.AttachmentBaseController] - Failed to validate file contents for type:

The quick and easy answer is to add that extension and content type to your "attachments.allowed-content-types" list and restart Search Server and xFlow services.  However this may not completely solve the problem.  The reason is that Service Point allows only one type of content for each file extension.  If you list more than one type of content per extension, for example ".rar:application/rar, .rar:application/vnd.rar, .rar:application/x-rar-compressed, .rar:application/x-rar", only the last content type for that file extension will be used. 

 

Resolution

The solution is to udpate the "attachments.allowed-content-types" list to add the association between the extension of the file and the MIME Type detected by Service Point.

  1. First, check the error message in the C:\Program Files\CA\xFlow\APPS\logs\incidentMS.log file to determine the exact MIME type that was detected.  For example, the blue highlighted value is the file extension of concern and the yellow highlighted value is the MIME Type
    ERROR - 2026-03-04 19:26:52 [c.c.c.f.security.FileValidator] - File extension (.rar) does not match the content type (application/x-rar-compressed; version=5)
  2. Log into Service Desk as an Administrator and go to > Administration tab > xFlow Interface > General

  3. Open "attachments.allowed-content-types" and click "Edit"

  4. In the Configuration Value field, add the extension and MIME type to the comma-delimited list in the format "<extension>:<MIME type>"  For example:
    .pdf:application/pdf,.txt:text/plain, .jpg:image/jpeg, .jpeg:image/jpeg, .png:image/png, .doc:application/x-tika-msoffice, .docx:application/x-tika-ooxml, .ppt:application/x-tika-msoffice, .pptx:application/x-tika-ooxml, .xls:application/x-tika-msoffice, .xlsx:application/x-tika-ooxml, .rar:application/x-rar-compressed; version=5
  5. Click "Save"

  6. Restart xFlow services.

Additional Information

MIME types

Manage Attachments in xFlow/Service Point

There is a website you can use to determine the content type for any file before trying to attach it in ServicePoint:

Detecting a file's mimetype

When you do encounter the error, you can check the content type of the file using the above website and compare with the settings of the attachments.allowed-content-types field and the error you find in the incidentMS.log file.