CA Service Desk Manager 17.1 Maileater intermittently stops processing emails
book
Article ID: 104133
calendar_today
Updated On:
Products
SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceKNOWLEDGE TOOLSCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
CA Service Desk Manager 17.1 Maileater intermittently stops processing emails.
Error messages similar to the following are seen within the NX_ROOT\log\MAILEATER_NXD.LOG files
"ERROR [ForkJoinPool-1-worker-3] c.c.S.m.ConnectSession - [mailbox:Mail_Eater:400001] Error processing email from: outlook.com:143 java.util.regex.PatternSyntaxException: Dangling meta character '?' near index 0 ......
at java.util.regex.Pattern.error(Unknown Source) at java.util.regex.Pattern.sequence(Unknown Source) at java.util.regex.Pattern.expr(Unknown Source) at java.util.regex.Pattern.compile(Unknown Source) at java.util.regex.Pattern.(Unknown Source) at java.util.regex.Pattern.compile(Unknown Source) at java.lang.String.replaceFirst(Unknown Source)
Cause
CA SDM 17.1 Maileater has issues processing emails if the incoming email body contains Regex special characters
For example, sending the following email to Maileater with the email body as: