Sysload Portal: How to create a Spreadsheet

book

Article ID: 103939

calendar_today

Updated On:

Products

CA Automic Sysload

Issue/Introduction

By working in a Spreadsheet, you work in an interface you are familiar with; it is similar to working in MS Excel. You have the ability to create new capacity metrics, that are the result of a consolidation of metrics contained in the Sysload database (Sysload GUI will help creating the data sources). You can easily create:
- Mashup metrics via standard formulas
- Customize the layout of the visualization



    How to create a Spreadsheet with Portal ?

    Environment

    Release: AUTYLA99000-1.0-Automic Sysload-ELA
    Component:

    Resolution

      Creating a Spreadsheet

      To create a new spreadsheet:

      • Select the "Create New" item from the main toolbar.
      • Click Spreadsheet.
      • A new and empty spreadsheet page is displayed. From this point forward, you can start to add a datasource to the spreadsheet.

      <Please see attached file for image>

      spread1

      New spreadsheet

      After you have selected the new spreadsheet option from the "Create New" menu, you will notice a “ribbon” type menu with various options displayed. The Font, Alignment, and Numbers are standard spreadsheet features and are self-explanatory. The File and Data menu are described below.

      <Please see attached file for image>

      ribbon

      Spreadsheet ribbon type menu

      The File Menu

      The file menu enables you to manage your spreadsheet, the features are explain in the table below.

      <Please see attached file for image>

      filemenu

      File menu options

      Item

      Description

      New

      Creates a new "empty" instance of a spreadsheet.

      Open

      The "Open" pane is displayed which lists all saved spreadsheets.

      Save

      Saves your current spreadsheet and displays the "Save" pane.

      Refer to Spreadsheet Parameters Pane Description

      Parameters

      Displays the "Parameters" pane. Enables you to modify your spreadsheet name and target folder.

      Refer to Save Pane Description

      XML Export

      Exports your spreadsheet in XML format using the following syntax yyyy-mm-dd_<spreadsheet_name>.

      Note: The date syntax correspond to the actual date of the download generation and not the spreadsheet creation date.

      Note: When you export a spreadsheet the datasource style is not exported.

      Your exported file can be opened in MS Excel. If you are using a version prior to 2011, then you may have to specify XML as the file type to open.

      Remove Sheet

      Removes current spreadsheet.

      The Data Menu

      <Please see attached file for image>

      Datamenu1

      New datasource

      <Please see attached file for image>

      Datamenu

      Data Menu Options

      Item

      Description

      New Datasource

      Opens the "New Datasource" pane.

      Refer to Spreadsheet

      Edit Datasource

      Opens the "Edit Datasource" pane.

      Click a cell in your spreadsheet, then select "Edit Datasource" to modify a Period, MO or Metric.

      Table Style

      Enables you to change the spreadsheet style with a selection of 5 predefined colors.

      Remove Datasource

      Removes all data contained in your spreadsheet.

      Adding a Datasource

      To add a new datasource:

      • Select "New Datasource" from the Data menu.

      <Please see attached file for image>

      datasource

      Data Menu

      • The "New Datasource" panel will be displayed.

      First, select a data period from the three available options. These options are identical to those shown in Dashboard designs feature. Refer to Global Period Pane Description

      Then select MOs and Metrics. This panel is identical to Dashboard Design panel. Refer to Widget Operations and Features

      <Please see attached file for image>

      newdatasourcepane

      • After selecting the Period, MOs and Metrics click Apply. Your datasource will be imported into the spreadsheet.

      By default, the spreadsheet displays 200 rows and 20 columns.

      <Please see attached file for image>

      portalspreadsheet

      Datasource

      Adding Formulas

      The space above the spreadsheet is used to create formulas. The "Formula" link can be used as an external reference to provide you with formula functions.

      <Please see attached file for image>

      count1

      Use known spreadsheet functions without leaving the Portal interface

      <Please see attached file for image>

      count2

      Feature provides same abilities as well-known spreadsheet programs

      <Please see attached file for image>

      functions

      Formula Functions Page

      Automic Sysload is not responsible for the content or updating external Webpages.

      To undo press CTRL+Z.

      Opening an existing spreadsheet

      There are 2 ways to open an existing Spreadsheet:

      1. Opening from the "Dashboards" list page.

      <Please see attached file for image>

      dash

      Spreadsheet in dashboard page

      We recommend that you create a specific folder for your spreadsheets.

      2. From the spreadsheet page, select Open from the displayed ribbon menu.

      <Please see attached file for image>

      ribbonmenu

      Open spreadsheet from the file menu

      <Please see attached file for image>

      open

      Opening an existing spreadsheet

      Spreadsheet Parameters Panel Description

      The panel is displayed when the "Parameters" option is selected on the Spreadsheet toolbar.

      Item

      Function

      Spreadsheet Name

      Spreadsheet name.

      Description

      Enables you to add a spreadsheet description. This may relate to the context of the spreadsheet or anything else you might find useful spreadsheet viewer.

      Target Folder(s)

      Enables you to select a target folder for your Dashboard from the displayed drop-down list.

      Apply

      To save click Apply.

      Cancel

      Cancels and closes the "Parameters" pane.

      Save Panel Description

      The "Save" panel operates the same way as the "Parameters", refer to the table above for descriptions. The pane is displayed only when you first "Save" your spreadsheet. If you want to edit your spreadsheet name or target folder you must use the "Parameters" option.

      We recommend that you create a specific folder for your spreadsheets using the "Folders" option found in the administration menu.

      <Please see attached file for image>

      savepane

      Attachments

      1558700048034000103939_sktwi1f5rjvs16jz5.txt get_app
      1558700046189000103939_sktwi1f5rjvs16jz4.png get_app
      1558700044131000103939_sktwi1f5rjvs16jz3.png get_app
      1558700042279000103939_sktwi1f5rjvs16jz2.png get_app
      1558700040615000103939_sktwi1f5rjvs16jz1.png get_app
      1558700038820000103939_sktwi1f5rjvs16jz0.txt get_app
      1558700037103000103939_sktwi1f5rjvs16jyz.txt get_app
      1558700035424000103939_sktwi1f5rjvs16jyy.png get_app
      1558700031946000103939_sktwi1f5rjvs16jyx.png get_app
      1558700030148000103939_sktwi1f5rjvs16jyw.png get_app
      1558700028384000103939_sktwi1f5rjvs16jyv.png get_app
      1558700026720000103939_sktwi1f5rjvs16jyu.png get_app
      1558700024914000103939_sktwi1f5rjvs16jyt.png get_app
      1558700023095000103939_sktwi1f5rjvs16jys.png get_app
      1558700021052000103939_sktwi1f5rjvs16jyr.png get_app