Autosys Web Server do not manage connections to more than one DB

book

Article ID: 103905

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

We need the webserver to connect to the WDBC database in failover on 3 addresses, but it does not work. 

Environment


Autosys 11.3.6 Sp5. 

Resolution

Update the tnsnames.ora as shown in the sample below:

AUTOSYS = 
(DESCRIPTION_LIST= 
(LOAD_BALANCE=off) (FAILOVER=on) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST=autorac1)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac2)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac3)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 


WCCDB = 
(DESCRIPTION_LIST= 
(LOAD_BALANCE=off) (FAILOVER=on) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST=autorac1)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac2)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac3)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 


WCCREP = 
(DESCRIPTION_LIST= 
(LOAD_BALANCE=off) (FAILOVER=on) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST=autorac1)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac2)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
(DESCRIPTION= (ENABLE=broken) (CONNECT_TIMEOUT=5)(TRANSPORT_CONNECT_TIMEOUT=3)(RETRY_COUNT=3) 
(ADDRESS_LIST= (LOAD_BALANCE=on) (ADDRESS=(PROTOCOL=TCP)(HOST= autorac3)(PORT=1521))) 
(CONNECT_DATA=(SERVICE_NAME=rac) (FAILOVER_MODE = (TYPE=none)))) 
)