ITPAM service not starting after installation
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ITPAM service not starting after installation

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Article ID: 103900

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After installing CA Process Automation with version 4.3 SP02, service not starting..
Found below errors in boot.log:
--------------------------------------------------------------------
INFO [SystemPropertiesInitializer] Initializing System properties for PAM 
ERROR [SystemPropertiesInitializer] SQL Error occurred while preparing properties table due to 
java.sql.SQLRecoverableException: IO Error: Connection reset 
at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:498) 

Environment

ITPAM version: 4.3 SP02

Cause

It is server/environment issue.

Resolution

Add below two lines to c2osvrd.sh and pamactivemq.sh as below and restart the PAM service.

For c2osvrd.sh file:

  • Go to <PAM Install Path>/server/c2o/
  • Open c2osvrd.sh file
  • Add below two lines at the end of section "SVRDEFINES":   
              -Djava.security.egd=file:/dev/./urandom
              -Dsecurerandom.source=file:/dev/./urandom
  • Save and close the file.
For pamactivemq.sh file:
  • Go to <PAM Install Path>/activemq/bin
  • Open pamactivemq.sh file
  • Modify ACTIVEMQ_OPTS as below:
    from 
    ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS_MEMORY -Djava.util.logging.config.file=logging.properties" 
    to 
    ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS_MEMORY -Djava.util.logging.config.file=logging.properties -Djava.security.egd=file:/dev/./urandom -Dsecurerandom.source=file:/dev/./urandom" 
  • Save and close the file.