CA Automation Suite for Data Centers - Configuration AutomationCA Client Automation - Asset ManagementCA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Remote ControlCA Client Automation - Asset IntelligenceCA Client Automation - Desktop Migration ManagerCA Client Automation - Patch Manager
Issue/Introduction
Asset Management job creates after successful processing the message "caft.dll not found" at the very end of the job:
Popup message
amagentsvc.exe - System error: ============================= X This application has failed to start because caft.dll was not found. Re-installing the application may fix this problem." <OK>
Cause
Not 100% determinated but It looks like some windows policy/settings is causing this problem.
Environment
Happened on a Win 10 1703 agent with ITCM 14 SP2 but can also happen on other versions of Windows or ITCM
Resolution
Put the CAM path(c:\PROGRA~2\CA\SC\CAM\bin) in the beginning of PATH environment variable