By integrating the servicenow-connector-installer-4.5.01 there is an error on the Step Test the CA Process Automation ServiceNow Gateway Functionality
If the request failed, scroll to the errorMessage field to understand the reason for the failure :
CreateTestTicket: Process failed to create test ticket - undefined: Sub-Process [ServiceNow/CreateTicket] returned error - Failed to assign incident parameters. Check incident parameters and try again
Cause
in the \Program Files\CA\PAM\server\c2o\log\c02.log file we can see the error message:
2018-06-28 10:02:27,450 ERROR [com.ca.connector.impl.util.BeanXmlHelper] [d0-c26c7463d2a8] Failed to convert XML to object - org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Package with uri 'http://ns.ca.com/2013/01/usm-servicenow' not found. (http:///temp.xml, 1, 253) java.lang.RuntimeException: org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Package with uri 'http://ns.ca.com/2013/01/usm-servicenow' not found. (http:///temp.xml, 1, 253) at org.apache.tuscany.sdo.helper.XMLHelperImpl.load(XMLHelperImpl.java:66)
Environment
servicenow-connector-installer-4.5.01 CA Process Automation 4.3 SP01 CA Catalyst Version 3.4.1.186 CA Service Operations Insight Version 4.0.2.77.20161104
Resolution
The problem is that the "com.ca.servicenow.descriptor.jar" file is missing in \ext-deploy folder. Please copy this file "com.ca.servicenow.descriptor.jar" from "c2o\.c2orepository\.c2ouserresources\ucf" to \ext-deploy and restarted PAM services.