CA Identity ManagerCA Identity GovernanceCA Identity Portal
Issue/Introduction
Identity Management Logging.jsp does not work as expected. When adding new category\classes in the logging.jsp, they do not persist and will disappear from the logging.jsp screen after a few minutes or when the browser session is closed.
The issue can be recreated as follows:
1. Load logging.jsp via the url (i.e. "http(s)://<IDM_NODE_ADDRESS>:8080/iam/im/logging.jsp" ) 2. In the "Set Logger" section at the top of the page, enter a class\ category that is not present in the default list
For example; ims.policyxpress ims.policyxpress.userlog com.netegrity.imsconfig.model.environment and com.netegrity.llsdk6.imsimpl.managedobject.ProvisioningRoleImpl
3. In the adjacent drop-down list select "DEBUG" and then click the "set" button. 4. Scroll down and check that the Category (i.e. ims.policyxpress) appears in the list and is set the adjacent logging value to "DEBUG". 5. Scroll down to the bottom of the page and select "Update".
After a few minutes (or when the browser session is closed) the values are reset to their defaults and the new class\ category settings are missing.
Cause
This is a non CA 3rd party issue with JBoss/Wildfly. The issue exists within the log4j api only.
Environment
IM vApp 14.1\14.2. IM software 14.1\14.2
Resolution
CA has produced a hot fix updating the following folder content with the previous release (working) material: "/opt/CA/wildfly-idm/modules/system/layers/base/org/jboss/log4j/logmanager/main". (log4j-jboss-logmanager-1.1.1.Final-redhat-1.jar and module.xml).
vAPP fix "HF-DE369815-20180627-0001.tgz.gpg" is available on request from CA Support.