caf could not start - The SM DLL cannot initialize
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caf could not start - The SM DLL cannot initialize

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Article ID: 103552

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction


Start of caf is failing. Error is :
 

Failed to connect: No master daemon was detected. The SM DLL cannot initialize.: SmInitialize
The command failed.

 


 
In DSM\logs\TRC_CF_CFSMSMD_*.log following errors appear :
 
CFSMSMD |OpenIdentityByNa|OpenIdentityByName_I|000000|ERROR  | No private key exists for this identity [dsmcommon]. Possible accidental import of DER file rather than PKCS#12?
CFSMSMD |CFSMCAPI |CFSMCAPI |000000|ERROR  | LoadIdentityComponent : Failed to load host public identity
 

Environment

Client Automation - All versions

Cause


This problem could occur if certstor.dat and/or cbbkstor.dat are corrupted under C:\Program Files (x86)\CA\SC\CBB

Resolution

The solution is to restore the corrupted .dat files from a similar working machine.
 

  • Copy the files C:\Program Files (x86)\CA\SC\CBB\certstor.dat and C:\Program Files (x86)\CA\SC\CBB\cbbkstor.dat from a similar working machine (with same ITCM plugins installed with same version) to the machine with problem.


 

  • Edit file C:\Program Files (x86)\CA\SC\CBB\certstor.dat with notepad and remove blocks of 4 lines containing reference to Computer Name with OU=itcm-self-signed




Example :



  • Remove blocks of 4 lines like these 



id=cert.b89cdd97b7116b7277beee8872c9936ebdf76ad4
data=
subj "CN=<computername>,OU=itcm-self-signed,O=ca" sn "01" skid "b89cdd97b7116b7277beee8872c9936ebdf76ad4" from 1530009522l to 1561635522l auth pvkey file "C:\Program Files (x86)\CA\SC\CBB\certdb\438F4032C4567B30F5F3E95DE23FBC954AA3E804.der"
end



 



  • Remove block of 4 lines for tag.itcm-anonymous like these :



id=tag.itcm-anonymous
data=
CN=<computername>,OU=itcm-self-signed,O=ca
end


 

  •  Execute these commands :



cacertutil list
caf start