The reports scheduler in Jasper reports server is not working

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Article ID: 103550

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The reports scheduler in Jasper reports server is not working , the following error is captured in the jasperserver.log files:

javax.mail.MessagingException: Could not connect to SMTP host: MAIL_SERVER_HOST, port: 25; nested exception is: java.net.ConnectException: Connection refused: connect

Cause

Jasper server is unable to connect to mail server due to a network or firewall block.

Environment

Jasper Reports 6.2.0 or higher
Service Desk 14.1 Cum 3

Resolution

Verify that the firewall or network is not blocking the connection to and from the mail server to the Service Desk Server.

1. Test with the ping command if the servers are reachable from the Jasper reports and Mail server.
2. Test with the telnet command to determine if the port is reachable from the Jasper reports server to the mail server.
3. Ensure that the Jasper Reports server is relay server list of the Mail server.

Additional Information

How to Use Telnet to Test SMTP Communication