ServiceDesk Notiifer fails to create ServiceDesk ticket when using HTTPS

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Article ID: 103534

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Updated On:

Products

CA Spectrum

Issue/Introduction

If you are using the $SPECROOT/Notifier/sd_notifier scripts to create tickets in ServiceDesk, the sd-integration configuration must be configured to use the http port. If you configure the integration to use the https port you will get a "Operation Successful" message when creating the ticket but it will not create the ticket in ServiceDesk.

Cause

The NotifiyOneclick executable which creates the ticket in ServiceDesk does not support https.

Environment

Spectrum 10.2.X
ServiceDesk
ServiceNow
Remedy

Resolution

Rerun the ServiceDeskIntegrationSetup.exe file and configure the OneClick port to use the HTTP port. or edit theĀ  sd-integration.cfg file to change the port manually. This requires HTTP to be configured in the $SPECROOT/tomcat/config/server.xml file.