VAIM policy state shows as "down" in VAIM when applying to a SystemEDGE host

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Article ID: 103457

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Updated On:

Products

CA Server Automation CA Virtual Assurance for IM

Issue/Introduction

When applying a Policy or Template to a SystemEDGE host using VAIM the status for all is "down".

Cause

  • VAIM uses CAM (CA-Message Queuing) to deliver policy files to SystemEDGE Hosts.
  • By default CAM will use both UDP (Port 4104) and TCP (Port 4105).
  • A state of "down" generally indicates one of two problems:
    1. SystemEDGE is stopped\not running on the host.
    2. There is an issue with CAM communication over UDP. 

Environment

Release: SEAUBC99000-12.9-Server Automation-Base Configuration
Component:

Resolution

1.  Make sure SystemEDGE is running.

2.  Force CAM to use only TCP (Port 4105) on the SystemEDGE host experiencing the "down" status in VAIM:

Unix

1) cd  /opt/CA/SharedComponents/ccs/cam/bin
2) ./camsave persist
3) cd /opt/CA/SharedComponents/ccs/cam
4) vi cam.cfg to make change
upd_port = 0
5) cd  /opt/CA/SharedComponents/ccs/cam/bin
6) ./camclose
Run ./camclose until you see the following
camclose: select failed (15) Unable to connect to CAM server
7) start sysedge (./sysedgectl start)

Windows

1. camsave persist
2. find cam.cfg file in %CAI_MSQ% and make edit.
udp_port = 0
3. cam change disabled & cam stop
4. cam change auto & cam start -c
5. start sysedge
 

Additional Information

  • The changes outline in this document are recommended for SystemEDGE endpoints only.
  • Do NOT disable CAM on CA VAIM Domain or CA VAIM Distribution servers.