Checkout for Browse system hangs with "EC=9" timeout
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Checkout for Browse system hangs with "EC=9" timeout

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Article ID: 103314

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Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister CA Harvest Software Change Manager

Issue/Introduction

Unable to check files for update or for browse.  The system hangs.
Error message - timeout or "pec EC=9"

Environment

CA Harvest SCM all versions and platforms

Cause

We temporarily disabled the firewall and found that the checkouts started to work normally after that.  So the ports that SCM needs to use had been closed in the firewall.

Resolution

Checked the /opt/CA/pec/standard/rtserver.cm to see if a direct connect port range had been configured for Harvest.  We found that the port range had been configured.

Adjusting the firewall to leave the ports in his port range open resolved the problem.

Additional Information

More information on direct connect port ranges can be found here: Configure Enterprise Communicator (PEC)

Look for the section titled "The Server Port Range"