System error, contact system administrator

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Article ID: 103278

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The problem is that end-users were getting a "System error, contact system administrator ." in the UI whenever they tried to view an GE SDLC custom object instance.

Cause

Investigating, we found this error message in the logs:

Error message in the logs: 

Caused by: java.sql.SQLSyntaxErrorException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00904: "ODF_CA_SDLC_REQUEST"."PRIVACY_DOCS": invalid identifier

This means that PPM cannot recognize the attribute PRIVACY DOCS on the custom object SDLC REQUESTS.

Environment

CA PPM 14.4 SaaS

Resolution

Deactivating and then activating the attribute resolved the problem.