Clarity upgrade fails if ppm_invalid_user's details vary from its seed data
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Clarity upgrade fails if ppm_invalid_user's details vary from its seed data

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Article ID: 103234

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

PPM_INVALID_USER is an account whose information is seeded under SRM_RESOURCES and CMN_SEC_USERS tables. Upgrades rely on this seed data to not change. Where there is a change, the upgrade fails.

Failure due to this issue, will have Errors such as the below logged in install.log:
An error such as the below is obtained during CA PPM upgrade.
Updating xogseeddata for component = infrastructure 
Applying PPM_INVALID_USER.xml 
/fs0/clarity1/clarity/.setup/scripts/db.xml:2352: The following error occurred while executing this line: 
/fs0/clarity1/clarity/.setup/scripts/db.xml:2568: The following error occurred while executing this line: 
/fs0/clarity1/clarity/.setup/scripts/db.macros.xml:105: Java returned: 2 
at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:568) 
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:443) 
at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105) 
at com.niku.tools.taskdefs.xpath.Iter.executeTarget(Iter.java:294) 
at com.niku.tools.taskdefs.xpath.Iter.execute(Iter.java:189) 

Applying XOG: Failure occurred while applying PPM_INVALID_USER.xml 
Check /fs0/clarity1/clarity/logs/xog-seeddata/out/infrastructure/PPM_INVALID_USER_out.xml for errors 
ERROR: Upgrade failed for tenant

Cause

Failure is caused due to changes in seed data of user 'ppm_invalid_user'.

Resolution

Run the following update queries, that will update this account with the original seed data prior to upgrade. For both the queries below, only one row each should be updated. If there is more than one row being updated, do not commit.

update srm_resources set last_name ='Invalid_User',
first_name ='PPM',
middle_name =null,
email ='[email protected]',
sms_email =null,
person_type = 300,
user_id ='-99',
date_of_hire=null,
date_of_termination=null,
manager_id =null,
is_active =0,
full_name ='Invalid User, PPM',
is_external=0,
external_source_id =1,
external_id =null,
use_in_frc_budget=0,
slice_status =null,
include_flag =1,
book_manager_id =null,
entity_code =null,
forecast_rate =null
where unique_name ='ppm_invalid_user'

update cmn_sec_users
set id ='-99',
user_name ='ppm_invalid_user',
pwd='977637977634d34664e6a4833494a7a6b6943073e5ad7c4022926c5c2c9aa4b124249',
pwd_required =null,
user_status_id =202,
obs_id =null,
description =null,
first_name ='PPM',
middle_name =null,
last_name ='Invalid_User',
email_address = '[email protected]',
sms_email_address=null,
photo_file =null,
locale='en_US',
timezone='Europe/London',
language_id =1,
country_id =1,
currency_code =null,
login_count=null,
bad_login_count=null,
force_pwd_change=1,
full_name =null,
company_id =0,
external_source_id =1,
external_id =null,
is_ldap=1,
use_proxy =0,
proxy_user_id=null,
home_url=null,
nav_state=0, 
bo_user=null,
screen_reader_opt =0,
high_contrast_ui=0,
no_csrf_msg=null,
salt='ywcM4fNjH3IJzkiC',
user_uid='ppm_invalid_user'
where user_name ='ppm_invalid_user'
 

Additional Information

Note: It is recommended to not change data of seed users that are placed out of the box in the Clarity Database.