New or migrated remote agent fails to start due to an "UnresolvedAddressException" error

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Article ID: 103095

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After installing or migrating a Remote Agent to a new domain the, agent does not start and is stuck in a SRVC_DOWN status. The below error is seen in the agent logs:

ErrorMsg: AwE-5107 awcomm connection error
Details: R:AMPROD appworx.ca.edu:2136 <- 0.0.0.0/0.0.0.0:0
awcomm connection error : R:AMPROD appworx.ca.edu:2136 <- 0.0.0.0/0.0.0.0:0 : java.nio.channels.UnresolvedAddressException

An nslookup command on the master's hostname from the agent will usually fail.

Cause

This is likely an issue with DNS not being configured correctly.

Environment

Release:
Component: APPMGR

Resolution

While referring to your network/server admin is recommended, possible solutions include the following:
  1. There is may be a missing resolv.conf file that is typically used to translate a hostname to an IP address. This issue can be encountered if the system doesn't have one,
  2. The agent's /etc/hosts file may be missing an entry for the Automation Engine's (master) server.