CA Workload Control Center retrieve job log error CAUAJM_E_10682
search cancel

CA Workload Control Center retrieve job log error CAUAJM_E_10682

book

Article ID: 103047

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

CA Workload Control Center returns the following error while viewing the job log: 
CAUAJM_E_10682 Requested log file for the specified job could not be found. 
E135001 There was an error trying to load the log: CAUAJM_E_10682 Requested log file for the specified job could not be found.
The Workload Automation AE Command line utility returns the following: 
# autosyslog -J <JobName> -tO
CAUAJM_E_10682 Requested log file for the specified job could not be found.
CAUAJM_E_50138 No agent files found for job <JobName>.

# autosyslog -J <JobName> -tE
CAUAJM_E_10682 Requested log file for the specified job could not be found.
CAUAJM_E_50138 No agent files found for job <JobName>.

# autosyslog -J <JobName> -tA
CAUAJM_E_10682 Requested log file for the specified job could not be found.
CAUAJM_E_50138 No agent files found for job <JobName>.

# autosyslog -J <JobName> -tS
CAUAJM_E_10682 Requested log file for the specified job could not be found.
CAUAJM_E_50138 No agent files found for job <JobName>.
There are several possible reasons for the error.

Environment

CA Workload Automation AE 11.3.+
CA Workload Control Center 11.3.+ and 11.4

Cause

One of the following scenarios could cause this problem.
  • The existence of the job logs and permissions on the files
  • Application Server Communication problems with the Agent

Resolution

The existence of the job logs and permissions on the files:
Ensure the files being retrieved (standard error, standard out and job logs) exists in the same directory as they were defined in the job.
The Job owner must have the appropriate permissions to retrieve the files
Click on the below link for troubleshooting procedures if the std_out_file and std_err_file are defined in the UNC path:
Job uses a UNC path in the std_out_file / std_err_file attributes
 
Application Server Communication problems with the Agent:
The Application Server renders the viewing or retrieving job logs(std_out_file/std_err_file). So it is absolutely necessary for the application server to be able to communicate with Agent.
Ensure the specified Communication requirements are met.
 

Additional Information

CA Workload Control Center "View a Prior Job Run Log "
CA Workload Automation AE "autosyslog Command" —Display Log Files