Error 500 on Browse in custom attribute - dynamic lookup on object Properties page
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Article ID: 102976
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Updated On:
Products
CLARITY PPM FOR ITGCLARITY PPM FEDERALClarity PPM SaaS - ApplicationClarity PPM On Premise
Issue/Introduction
When going to object properties page, clicking on the custom lookup Browse icon, a popup opens with message: Error 500 - Internal Server Error. The server could not retrieve the document due to server-configuration or other technical problems. Contact your site administrator.
Error message in the app-ca.log: ERROR 2018-06-19 11:07:19,425 [http-nio-14001-exec-25] lookup.BaseLookupService (clarity:admin:11823484__11F6E12D-E43E-4E98-BE92-E9C2C8A3919C:odf.browsePage) Unable to get lookup values for lookup TEST_LOOKUP for browse page support com.niku.union.odf.lookup.LookupException: Could not fetch values for the NSQL at com.niku.odf.service.lookup.DynamicBrowseLookupService.getLookupValues(DynamicBrowseLookupService.java:577) at com.niku.odf.service.lookup.BaseLookupService.toXML(BaseLookupService.java:111) at com.niku.odf.service.lookup.BrowseLookupService.doProcess(BrowseLookupService.java:70) at com.niku.odf.service.ODFActionService.processRequest(ODFActionService.java:113) at com.niku.union.service.binding.ServiceControlBindingJava.processRequest(ServiceControlBindingJava.java:58) at com.niku.union.service.ServiceControlImpl.processRequest(ServiceControlImpl.java:914) at com.niku.union.service.ServiceControlImpl.processRequest(ServiceControlImpl.java:212) at com.niku.union.web.WebServiceAdapter.processRequest(WebServiceAdapter.java:219) at com.niku.union.web.PortletController.processServiceRequest(PortletController.java:1431) at com.niku.union.web.PortletController.processAuthorizedPortlet(PortletController.java:914) at com.niku.union.web.PortletController.processPageActionRequest(PortletController.java:399) at com.niku.union.web.PortletController.processRequest(PortletController.java:166) at com.niku.union.web.WebActionController.processAction(WebActionController.java:1435) at com.niku.union.web.WebActionController.processRequest(WebActionController.java:178) at com.ca.clarity.uif.service.vxml.VXMLService.processRequest(VXMLService.java:453) at com.ca.clarity.uif.UIServlet.service(UIServlet.java:77) at javax.servlet.http.HttpServlet.service(HttpServlet.java:742)
Cause
This is most likely caused by an issue with the NSQL query getting corrupted in the cache.
Environment
Release: Component: PPMSTU
Resolution
Workaround:
1. Connect with admin user to CA PPM UI and go to : https://<SERVERNAME:PORT>/niku/nu#action:security.caches 2. Go to Groups Tab 3. Select: Custom Objects Lookups PMD 4. Click Flush
Additional Information
If the issue recurs, open a case with Product Support and refer to this KB article.