Unable to start CADDSPLx - Receiving CADD097E already active and CADD099E init error
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Unable to start CADDSPLx - Receiving CADD097E already active and CADD099E init error

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Article ID: 102943

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Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

We had an emergency IPL today. So Dispatch and the CADDSPLx environment were not brought down cleanly. When attempting to restart the CADDSPLx environment with the standard S CADDSPLx command, we are receiving:

CADD097E CADDSPLx already active
CADD099E CADDSPL initialization error, shutting down
CADDSPL1 - STEP WAS EXECUTED - COND CODE 0012

Environment

z/OS

Cause

Error or Warning condition. An attempt was made to start a CADDSPL, but this CADDSPL is found to be already active. Only one instance of each CADDSPL address space can be active at a time. During a normal initialization, this message is issued as an Error condition and the CADDSPLI stops immediately.
 
* If this message is issued when there is no CADDSPL address space running, it is because of a corrupted control block. 

Resolution

In this case, a FORCE option can be specified on the CADDSPLx start up to allow the restart of the CADDSPL.

Note that if the FORCE option is specified, the message will be changed to a Warning level and will be followed by the CADD113W message.

Action: Do the following:

1. Determine if CADZSPLx address space is already active.
  • Note: Starting the CADDSPL twice can lead to unpredictable results and the FORCE option bypasses the safe guards that normally prevent you from starting CADDSPL twice.
 
2. If the CADZSPLx address space is not active, restart the CADDSPLx environment with the FORCE option coded on your start command as:

/S CADDSPLx,,,FORCE