Process Automation - Install is failing after providing Java install location
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Process Automation - Install is failing after providing Java install location

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Article ID: 102889

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Updated On:

Products

CA Process Automation Base Process Automation Manager

Issue/Introduction

Site is attempting to install ITPAM 4.3 as part of the Service Management Install, previously SQL client and JRE 1.8 were installed.

PAM Installer is asking for the Java Home Directory and getting an error to enter a valid Java install directory, even through the displayed path is the correct one

Error presented is:  Please enter a valid 64-bit Java Runtime Environment (JRE) 7 or above installation directory path.

Environment

CA Service Management 17.x

Process Automation 4.3.x

Cause

The error is due to the environment being given the location of a Java Runtime (JRE) install.  The application installer should be given a Java Development Kit (JDK) install.

Resolution

Please download JDK install at 1.8 level.  Downloads can be obtained at http://java.sun.com

Once JDK has been downloaded and installed, the application should pick up on the JDK install and proceed further.

Additional Information

In the above screenshot illustration, the install interview display mentions to supply the location of JDK, but the error references a JRE location.  Research confirms that it is a JDK that must be in place in order for the installer to complete.