Users are unable to log into Unified Self Service after changing password in Active Directory

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Article ID: 102830

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When USS is connected to EEM and EEM connected to LDAP. After updating a password of an end user in the LDAP server, users are not able to log into the application and the following error appears:

Authentication failed. Please try again.

The log file lifferay.log will show something similar to the following:
 
ERROR [EEMLogin:120] Error during authentication in EEM
[Authenticate Error: Authentication Failed, Authenticate Error: Authentication Failed, Identity Attempted: USERID]
com.ca.eiam.SafePasswordException: EE_AUTHFAILED Authentication Failed
            at com.ca.eiam.SafeContext.authenticateWithPassword(SafeContext.java:1716)
            at com.ca.eemauth.EEMLogin.authenticateByScreenName(EEMLogin.java:234)

Cause

The new password is not recognized by the application the liferay authentication framework.

Environment

Unified Self-Service 14.1 and later
EEM 12.5 an later
 

Resolution

1. Go to the USS server > Edit the portal-ext.properties
2. Set the following variables:

bypass.liferay.screenname.validation=true
auth.pipeline.enable.liferay.check=false


3. Save Changes and Restart both USS Services
 

Additional Information

When attempting to login to Unified Self Service with a username that have multibyte characters and non-English characters the login fails

Users are unable to log into Unified Self Service