Introscope WebSphere agent does not connect to the Enterprise Manager

book

Article ID: 102674

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

The agent will load and create logs but it will not be able to connect to the Enterprise Manager.
You will see this error:

                         [ERROR] [IntroscopeAgent.Agent] An error occurred while trying to connect to the Introscope Enterprise Manager

If VERBOSE or DEBUG logging is configured, you will get this specific error:

                        [VERBOSE] [IntroscopeAgent.Agent] java.lang.NoSuchMethodError: com/wily/introscope/agent/enterprise/EnterpriseAgent.access$300

Cause

This can be specifically relevant where some WebSphere instances only selected WebSphere instances are monitored on the same machine

Environment

10.3 agent monitoring WebSphere 8.5 Java 1.7

Resolution

Add this JVM parameter to the WebSphere startup:

              -Xshareclasses:none

Additional Information

IBM documentation on class sharing

https://www.ibm.com/support/knowledgecenter/en/SSYKE2_7.0.0/com.ibm.java.lnx.70.doc/diag/appendixes/cmdline/Xshareclasses.html