Installing CA Tools r20 gives APPLY errors with CUM Service because of missing SMPE resources

book

Article ID: 102477

calendar_today

Updated On:

Products

CA RC Compare for DB2 for z/OS CA Database Analyzer for DB2 for z/OS CA Fast Unload for DB2 for z/OS CA Fast Check for DB2 for z/OS CA Fast Index for DB2 for z/OS CA Fast Load for DB2 for z/OS CA Rapid Reorg for DB2 for z/OS

Issue/Introduction

APPLY CHECK processing: GIM24608E ** SHELLSCR ENTRY PDTAAMKD IS NEEDED TO PROCESS HFS PDTUICTX FOR SYSMOD SO01396

We are in the process of doing a clean r20 install on one of our z/OS LPARs.
We already managed to APPLY / ACCEPT r20 Base Level 17/04 to our SMP/E environment.
Trying to APPLY the latest CUM Service we run into errors doing APPLY CHECK processing:
GIM24608E ** SHELLSCR ENTRY PDTAAMKD IS NEEDED TO PROCESS HFS PDTUICTX FOR SYSMOD SO01396,
BUT SHELLSCR PDTAAMKD IS NOT IN THE CAIT0 ZONE.
Also for the following enty: SHELLSCR ENTRY PXMDSSMP We do not find any UCLIN job to add the resources referenced in the SMPE error messages ?
Can you please adviseĀ 

Environment

z/os DB2

Resolution

All the error messages GIM24608E ** SHELLSCR ENTRY PDTAAMKD IS NEEDED TO PROCESS HFS ...... point to PTF SO01396.
Found another case with this exact problem.
Looks like it was due to a corrupted SO01396.
That is by corrupted I mean likely truncated.
That could have happened downloading the maintenance to your system.
The only way around it was to remove the current SO01396 from the system and download a new version from our system ensuring the download works without any problems.