New UX: When resetting the password, PPM does not verify that the New Password and Confirm password data given match. Even if those do not match, password gets reset
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Article ID: 102467
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Updated On:
Products
CLARITY PPM FOR ITGCLARITY PPM FEDERALClarity PPM On Premise - ApplicationClarity PPM On PremiseClarity PPM SaaS
Issue/Introduction
New UX: When resetting the password, PPM does not verify that the New Password and Confirm password data given match. Even if those do not match, password gets reset
STEPS TO REPRODUCE: 1. Log in to PPM and ensure new UX is enabled. 2. Go to Administration > Organization and Access > Resources 3. Edit any user profile and add your email address ad user email address. 4. Go to the new UX URL, let say: http://emea154sp1/pm 5. Click on Forgot Password 6. Enter the user name you want to have the password reset 7. You will receive an email like:
We have received a request to reset your CA PPM™ password. To proceed, please click on the following link. http://emea154sp1/pm#changepassword?userName=joxi&code=VeFwJVyVQmh5BmUZ4js1k
8. Open the link and you will find a window where you need to enter the new password 9. Give as a New Password: Mynowpwd Confirm Password: Mynewpwd 10. Submit it
Expected Result: I should be alerted that both passwords given do not match. Actual Result: Password gets reset to Mynowpwd and no alert is given about password matching. As a typo was made when entering the password, I am not able to log in.
Cause
This is caused by DE41973
Environment
Release: Component: GROUPS
Resolution
Workaround: Reset password again in new UX or reset it in the Classic UI