cannot receive threshold events from NetOps Portal into Spectrum
search cancel

cannot receive threshold events from NetOps Portal into Spectrum

book

Article ID: 102441

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Performance Management Integration Configuration - event polling enabled in Spectrum OneClick Web Console.
Only one IP Domain (Default Domain) Monitored device added into global collection (Default Domain).
Created a threshold profile an applied to a group where the monitored device belongs.
I can see the threshold event of CPU Violation in NetOps Portal I cannot see that event in Spectrum.

Environment

DxNetOps: All Supported Versions
Spectrum: All Supported Versions
 
Spectrum added as a Data Source.
Event polling enabled.
 

Cause

From Catalina.out on the Spectrum side:
2018 12:21:57 PM (PoolThread-18932: GlobalPool => RubiconEventPoller) (org.apache.axis2.transport.http.impl.httpclient3.HTTPSenderImpl) - (INFO) - Unable to sendViaPost to url[http://hostname:8281/EventManager/EventManagerWS.asmx]
java.net.UnknownHostException: ourcapchost
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)

from DMService.log on NetOps Portal host:
ERROR|pool-2-thread-15|2018-06-13 05:01:45,559|com.ca.im.portal.dm.productsync.DataSourcePoller|
Data source Spectrum Infrastructure Manager@IP did not respond to a sync request within the timeout interval. The problem is in the data source, not CAPC. Check the logs for the data source to determine why it did not respond. The following stack trace shows the context of the sync request:
javax.xml.ws.WebServiceException: Could not send Message.
 
ERROR|pool-2-thread-23|2018-06-13 08:59:55,854|com.ca.im.portal.dm.productsync.DataSourcePoller|
Data source EventManager@ourcapchost encountered an error while processing a sync request. The problem may be in either the data source or CAPC. The following stack trace may indicate where the problem lies. You may also want to check the logs for the data source to determine if it is the cause of the problem.
java.lang.NullPointerException
 

Resolution

This was caused by incorrect name resolution in DNS.
Fixed DNS and all is working.