Tomcat 8.5.x Agent Compatibility

book

Article ID: 102340

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction



We want to run the Tomcat agent on a RHEL server. 

The agent is not producing any metrics so need to confirm if this Tomcat agent and EM are compatible with Tomcat 8.5. The compatibility guide for Introscope 10.5.2 says:

Tomcat 6.x, 7.x, 8.x
Red Hat Linux 5.x, 6.x, 7.x and Compatible Linux Variants
JRE: 1.6, 1.7, 1.8


Please confirm agent and EM version needed to monitor Tomcat 8.5.

Environment

Versions are:

EM version: 10.5.2
Server OS: Red Hat Enterprise Linux 7.x
Apache Tomcat version 8.5
Java runtime: 1.8

Resolution

Compatibility Testing Staff mentioned Tom 8.5 was tested and supported
 

Additional Information

 See https://pcm.ca.com/overview.php?mod=overview&solution=apm10.5.x for 10.5.x Tomcat Support.