Troubleshooting ACF89810 UNABLE TO IMPLANT DELETE CDE HOOK
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Troubleshooting ACF89810 UNABLE TO IMPLANT DELETE CDE HOOK

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Article ID: 102330

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Updated On:

Products

ACF2 ACF2 - z/OS ACF2 - MISC

Issue/Introduction

An ACF89810 error message is seen right after ACF2 initialization. What is causing this error and how can it be fixed?

Example of messages seen in the console:

ACF89888 ACF2 SUBSYSTEM INITIALIZATION IN PROGRESS 
IEF196I ACF89810 UNABLE TO IMPLANT DELETE CDE HOOK 
*ACF89810 UNABLE TO IMPLANT DELETE CDE HOOK 
ACF89890 ACF2 SUBSYSTEM INITIALIZATION COMPLETE 
CAS2031I CA SAF interface initialization complete

Cause

The most common cause of the ACF89810 error message is missing compatibility fixes.

Other causes could be by either picking up old ACF2 Linklib/LPA libraries or not copying runtime library properly.

Resolution

  1. Verify that all ACF2 z/OS compatibility fixes are applied. See the z/OS Compatibility Matrix to verify which fixes are required.

  2. Verify that DSN SYS1.NUCLEUS contains module CSVSBRTN in your IEANUCxx member. Make sure it is current by looking for the eyecatcher.

  3. By using TSO ISRDDN or TSO CAMODID verify the RMID of CSECT ACF89CDE in any module related to it. It is included in several other ACF2 modules such as module ACF89SIP.

    The RMID should be current based on the version of z/OS. RMIDs as of March, 2026 include:

    z/OS 3.1 with IBM PTF OA66032 or z/OS 3.2: LU16693
    z/OS 3.1 base without IBM PTF OA66032: LU09157
    z/OS 2.5: LU10561
    z/OS 2.3: RO95218

    Here in an example of locating the z/OS 2.3 ACF2 RMID RO95218 for ACF89CDE in acf2hlq.CAX1LINK(ACF89SIP):

    .......-ACF89CDE........AC89CDE#........CMCTABLE...... AC89CDE@...&...0ACFF1MFS
    ................................................................................
    ...5695PMB01 ........¬
    ..........569623400 .....
    ..h......RO95218
    ............ .. ...........0
    x4..y....#MID......y....ACF89CDE CAX1G00 ~RMID(RO95218)~ 20161118 17.26 .......
    .......................U...4....... ...&...h...q...Q.......................U....

  4. Make sure the runtime library is up to date and if copying, that nothing is missing or out of sync. 

 

Additional Information

If the above has been verified and the issue still persists, please gather evidence that the steps provided were completed as well as a stand-alone system dump and contact Broadcom Support.

The ACF89810 message is documented in the Messages for ACF2 for z/OS guide.