CA PPM: Submitted timesheet does not appear to be able to be approved in New UI
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Article ID: 102108
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Updated On:
Products
CLARITY PPM FOR ITGCLARITY PPM FEDERALClarity PPM SaaS - ApplicationClarity PPM On Premise
Issue/Introduction
In the new UI, we have a timesheet for a user that shows as submitted, but if we go to the "Review and Approve" tab, it does not show up there for us to be able to approve or reject it.
Cause
The problem was caused by the fact that the resource for which this time sheet was submitted, had a hire date set to a date after the period for that submitted time sheet.
For example: "User-A" has a hire date set on their resource record as 6/1/2018 A timesheet was submitted for this user for the time period of 5/20/2018-5/26/2018 Because the hire date of the user is after the specified time period on the timesheet, the timesheet wont display in either the classic UI, nor the New UI
Environment
CA PPM - 15.3 and above
Resolution
To be able to view this submitted timesheet, we had to change the hire date on the resource to a date that was before the start of the time period on that submitted time sheet. After doing so, we are now able to see the timesheet in both Classic and New UI.