No Reply from OS Installation Manager. [OSM009006] when launching DSM Explorer

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Article ID: 101599

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

Unable to open DSM explorer because of a configuration manager interaction issue what presents as an OSIM error. This will typically happen on a single machine, like the Domain Manager and not be a problem on other systems.

Cause

This issue can happen when a specific process becomes orphaned from CAF and CAM by having it's communication pipe severed or timed out under the covers but never actually shutting down. In this case the exe is CCSMAPID.EXE. When this happens, neither CAF STOP, CAF STOP ALL, nor CAF KILL ALL will terminate this process. If CAF is restarted, you will see 2 instances of CCSMAPID.EXE and if you run CAF stop CCSMAPI or CAF KILL CCSMAPI, only one of the two will be killed. The other is not even seen by CAF as running.

Environment

Any supported DSM Explorer OS

Resolution

The simple solution is to stop CAF or run CAF KILL CCSMAPI to shut down the functional copy, if it exists, then open Windows Task Manager, find the offending CCSMAPID.EXE process and kill it manually. Once down you can run CAF START or just CAF START CCSMAPI and a new instance will start up and within 1-2 minutes, normal functionality will return and DSM Explorer will be launch-able once more.