Rally - SSO: Email Addresses has Changed to ID
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Rally - SSO: Email Addresses has Changed to ID

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Article ID: 101589

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

We have noticed on the user profile, the email address has been changed by "System User" to their employee ID.  

Environment

Release:
Component: ACSAAS

Cause

Email functionality was disabled. When email functionality is disabled in Agile Central, the system only requires the username, which it calls "EMAIL ADDRESS". 



If a user logs in via SSO with a username that is different than their previously-set email address in Agile Central WHILE email functionality is disabled, the System User will update the username (EMAIL ADDDRESS) with the username provided as the SAML subject via SSO.  This is because the system is using only this one field - and the SSO credentials provided map to the same user, thus the system updates the username to match. 

When Email Functionality is re-enabled, the username is copied to the email address by the system, and thus displayed. 

 

Resolution

Users can go back in and update their own email addresses, or a customer could leverage a custom (unsupported) script to update the email addresses to their previous values. Agile Central Engineering does not have a way to restore previous values.