Client Automation - camping and/or caf ping fail between Scalability Server and Domain Manager
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Client Automation - camping and/or caf ping fail between Scalability Server and Domain Manager

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Article ID: 100827

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

Unable to camping or caf ping between Scalability Server (SS) and Domain Manager (DM). You cannot camping or caf ping either way between DM and SS.

Environment

Any Supported ITCA / ITCM environment

Cause

There may be a UDP packet issue between the SS and DM, preventing proper communication. UDP does not have error correction or guaranteed delivery, so any UDP issues can be critical. While a reduced/fixed packet size for UDP is generally the preferred solution for client machines, a switch to CAM using TCP is preferred when the problem system is a Scalability Server. This is because TCP is a 'Heavier' protocol and too many clients using it can degrade performance, but Scalability Servers are fewer in number and more critical and thus justify the change.

Resolution

This can happen if there is an issue with UDP packets between two points; in this case, a Scalability Server(SS) and Domain Manager (DM).
To solve this problem, since it is an SS, you can convert CAM to use TCP when communicating with the DM. It will still use UDP to communicate with agents and not generate too much overhead from TCP use.

NOTE: This is not recommended for more than a few hundred clients in an environment as the overhead generated can negatively impact performance in higher numbers.

PROCEDURE:

1. Browse to %CAI_MSQ% and check for a file named CAM.CFG. (This file will not exist by default)
2. If you do not find one, create an empty text file in that folder and edit it to contain the following, adding your DM name where indicated:

# CAM config saved: Mon Jun 11 12:56:18 2018
*CONFIG
fixed_paths = no
close_time = 60
client_hold = 60
connect_retry = 60
udp_port = 4104
tcp_port = 4105
dg_log_files = 8
dg_log_size = 64
dg_log = *
au_log_files = 8
au_log_size = 256
au_log = *
tr_log_files = 8
tr_log_size = 1024
tr_log = *
trace = none

*PATHS
<DM FQDN>     protocol = tcp  port = 4105

*ROUTING

*AUDIT
off

3. Save the file and rename to CAM.CFG
4. If you DO have a CAM.CFG file, just add this line under the *PATHS section:

<DM FQDN>     protocol = tcp  port = 4105

5. Now reboot the SS and you are done.