Timeout issues when deploying a large VSM to the VSE
search cancel

Timeout issues when deploying a large VSM to the VSE

book

Article ID: 100720

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder) Service Virtualization

Issue/Introduction

When deploying a large MAR file to the VSE, I am getting timeout exceptions and the VSM is not deployed.

Environment

All supported DevTest releases.

Cause

  • This issue can happen when McAfee AV is in place and scan the Virtual Services being deployed to the VSE.
  • The agent can take time to scan the large file what causes the deployment process to timeout.
  • If the VSI is large , you would expect delays. 

 

Resolution

There are two things that can be done:
1. Configure McAfee AV agent to not scan the files with the .vsi and .vsm extensions. or  Have the VSE running in an environment where McAfee AV is not available.

OR

2. Timeout can be caused by some delays when deploying a large VSI.


If that is the case you can add the following property to the Workstation's local.properties file and restart:

lisa.net.timeout.ms=840000  (in millisecs)
This property will increase timeout from the workstation while deploying.  

Additional Information

 
 
More information click on link: Not able to deploy large VSM file