e2e script returns -3 error when run from the probe (but not the nimrecorder)
search cancel

e2e script returns -3 error when run from the probe (but not the nimrecorder)

book

Article ID: 100546

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The e2e_appmon_dev probe was deployed to the target robot. This probe was used so that the nimrecorder script editor is also installed on that server for use in editing/revising scripts as needed. A script was created which runs perfectly when run manually from the nimrecorder script editor. Once a profile for the script is created and the run is attempted from the e2e probe itself (either when the profile is first activated or when the right click menu is accessed and the 'Start at once' option is selected) the status quickly returns a -3 error code status and the script is not run at all (as per observation of the script via remote viewer, e.g., RealVNC, TightVNC etc.)

Environment

Release: any UIM release

e2e_appmon probe v2.40

Cause

When the UIM robot is installed on a drive other than C:, the e2e_appmon_dev probe deployment installs the nimrecorder with all the e2e bin files on the C: drive, which places the taskexec.exe on the C: drive as well. When the UIM robot is installed on a drive other than C:, the probe deployment of the e2e_appmon_dev probe installs the recorder with all the bin files on the C: drive. This places the taskexec.exe on the C: drive. The e2e_appmon_dev probe config defaults to a path 'relative to the probe install,' so the taskexec.exe isn't found and subsequently you get a -3 error code.

Below is the default e2e probe configuration for the pathing to the taskexec.exe file and the location of the compiled scripts. Note: as mentioned, as per current probe design/defaults, it is relative to the probe installation directory.

   rob_file_dir = "../../../e2e_scripting/scripts"
   command = "../../../e2e_scripting/bin/taskexec.exe"

Resolution

There are two options to correct the situation.

a) either edit the path in the e2e_appmon_dev probe config


b) uninstall the nimrecorder and then run the nimrecorder install manually and specify where to install it with the "Options." This option solves two issues with the probe configuration pathing. The taskexec path and the path to the scripts folder (since the original install was saving and compiling in the scripts folder on the C: drive.)

Once all the executable files for both 'editing' and 'running' the scripts were in the same bin folder, the probe ran the scripts perfectly without error.

Attachments

1558701426250000100546_sktwi1f5rjvs16kic.png get_app