Unable to login to xFlow after successfully upgrading
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Unable to login to xFlow after successfully upgrading

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Article ID: 100431

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When trying to login to xFlow after an upgrade, the login fails

Environment

CA Service Desk Manager 17.x

xFlow

All Supported Operating Systems

Cause

The data from the r17_1_insert.dat file located in the  NX_ROOT/data directory was not properly loaded into the database when SDM was upgraded. 

Resolution

The error of interest reads as:  "Oops! You do not seem to have access. Contact the system administrator."




This is the error that is normally seen when the access type of the user logging in does not have xFlow associated with their access type. Additionally, if you check the UI under  Administration -> xFlow Interface, the first item "App Configuration" may be missing from the list.


To correct for this, access a Command Prompt on the SDM Server (make sure you are using an Administrative Command Prompt), change the directory to NX_ROOT/data and execute the following command:

pdm_load -f r17_1_insert.dat

You should now see "App Configuration" as the first option under Administration -> xFlow Interface and login to xFlow should now be successful.