CA 7 WEB UI 11.3.4 USS Mainframe: Installer User Interface Mode Not Supported
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CA 7 WEB UI 11.3.4 USS Mainframe: Installer User Interface Mode Not Supported

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Article ID: 100152

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CA 7 Workload Automation

Issue/Introduction

Trying to install CA7 WebClient 11.3.4, when launching the setup.sh installer on Linux, it can fail with the following output :

R011 at SB06 /bbbbb/CA/ca7webclient1134/insttmp> ./setup.sh                                
--------------------------------------------------------------------------------           
                                                                                           
Invoking CA Workload Automation CA 7 Edition Web Client 11.3.4 Installer . . . . . .       
                                                                                           
Please Review CA Workload Automation CA 7 Edition Web Client 11.3.4 license agreement.     
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                             
In 10 seconds the Installer will place you in a browse session where the                   
CA license agreement is displayed.                                                         
After reviewing the agreement, exit from the file by using end / exit                      
(PF3) commands.                                                                            
                                                                                           
Accept / Disagree License Agreement                                                        
~~~~~~   ~~~~~~~~ ~~~~~~~~~~~~~~~~~                                                        
                                                                                           
If you agree to the License Agreement, please enter 'Y' to continue with                   
CA Workload Automation CA 7 Edition Web Client 11.3.4 Installation.                        
If you disagree, please enter 'N' to exit CA Workload Automation CA 7                      
Edition Web Client 11.3.4 installation.                                                    
Y                                                                                          
                                                                                           
                                                                                           
                                                                           
=======================================================                    
                                                                           
Installer User Interface Mode Not Supported                                
                                                                           
Unable to load and to prepare the installer in console or silent mode.     
                                                                           
=======================================================                    
                                                                           
R011 at SB06 /bbbbb/CA/ca7webclient1134/insttmp>  

     

Environment

Red Hat Enterprise Linux Server

Cause

The problem relates to the presence of the DISPLAY system variable - used by X11 environments. If this is set to a location that is not reachable the problem occurs. If it is set to a location where an accessible X11 server is running then the installer continues - in console mode

Resolution

To resolve this problem if you do not have an accessible X11 environment simply unset the DISPLAY variable and relaunch the installer.

To check if the DISPLAY variable is set enter command :

  R011 at SB06 /u/r011> echo $DISPLAY 
  :0.0 
  R011 at SB06 /u/r011> 

in this case the variable is set to value '0.0' and with this value the error occurs. 
To clear it,  issue commands: 

  R011 at SB06 /u/r011> unset DISPLAY 
  R011 at SB06 /u/r011> echo $DISPLAY  
  : 
  R011 at SB06 /u/r011> 

now the echo $DISPLAY is returning nothing (DISPLAY variable is empty) and this will solve the problem.

If the error still occurs , Please open a case with Technical Support.